Post

OSPF Network Types


OSPF Network Types

In OSPF, there are 5 different types of connections between routers:


x

  • Point-to-Point (P2P):
    In a Point-to-Point connection, OSPF is configured between two directly connected routers. This type of connection is typically used in scenarios where there is a single link between two routers. P2P connections don’t require the use of DR/BDR (Designated Router/Backup Designated Router) election.


x

  • Broadcast:
    In a Broadcast network type, multiple routers are connected to a same network segment. In this type of network, OSPF routers elect a DR and a BDR to reduce the amount of OSPF traffic and improve efficiency.
  • Non-Broadcast Multi-Access (NBMA):
    NBMA networks are similar to Broadcast networks but lack the automatic broadcast capabilities. In NBMA networks, OSPF routers can’t rely on automatic DR/BDR election due to the lack of broadcast, so the neighborship adjacency needs to be configured manually


x

  • Point-to-Multipoint (P2MP):
    In a Point-to-Multipoint connection, a router is connected to multiple remote routers as if it were a point-to-point link with each of them, but are still in the same segment. P2MP connections simplifies OSPF configuration and doesn’t require DR/BDR election.
  • Point-to-Multipoint Non-Broadcast (P2MNB):
    Similar to P2MP, P2MNB connections are used in a network with no broadcast connectivity. Neighborship adjacency is configured manually.



Point-to-Point (P2P)

x

Here’s the configuration for point-to-point connection between XE1 and XE2

XE1

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.1 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0

XE2

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.2 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0


And if we check the neighbor status, they should discover each other

x


Checking the OSPF type, it shows that it is indeed a point-to-point connection

x



Broadcast

x

Here’s the configuration for broadcast connection between XE1, XE2 and XE3

XE1

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.1 255.255.255.0
 ip ospf network broadcast
 ip ospf 1 area 0

XE2

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.2 255.255.255.0
 ip ospf network broadcast
 ip ospf 1 area 0

XE3

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.3 255.255.255.0
 ip ospf network broadcast
 ip ospf 1 area 0


If we take a look at the neighborship adjacency status, we can see all 3 routers have discovered each other, with an additional information about the DR/BDR roles

x

Here XE3 is elected as the DR because it has the highest router-id number, followed by XE2 as the BDR, while XE1 remains in DROTHER status.

  • DR (Designated Router): DR is responsible for performing LSA flooding tasks to the entire segment.
  • BDR (Backup Designated Router): The BDR is the router that takes over as the DR if the current DR fails.
  • DROther (DR Other Router): DROther routers are OSPF routers that neither hold the DR nor the BDR role.


And if we check the OSPF connection type, it’ll show broadcast.

x



Point-to-Multipoint (P2MP)

x

Here’s the configuration for P2MP connection between XE1, XE2, XE3 and XE4

XE1

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.1 255.255.255.0
 ip ospf network point-to-multipoint
 ip ospf 1 area 0

XE2

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.2 255.255.255.0
 ip ospf network point-to-multipoint
 ip ospf 1 area 0

XE3

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.3 255.255.255.0
 ip ospf network point-to-multipoint
 ip ospf 1 area 0

XE4

1
2
3
4
interface GigabitEthernet2
 ip address 99.0.0.4 255.255.255.0
 ip ospf network point-to-multipoint
 ip ospf 1 area 0


Checking the neighbor status, we see all the routers have been discovered, but what different from broadcast is there’s no DR/BDR election

x


And this also shows the type to be a pont-to-multipoint

x



Non-Broadcast Multi-Access (NBMA) & Point-to-Multipoint Non-Broadcast (P2MNB)

For NBMA & P2MNB, the configuration is pretty much the same, but because the lack of broadcast/multicsat traffic, we have to manually build the neighborship adjacency with this command from one router side

XE1

1
2
3
4
router ospf 1
 neighbor 99.0.0.2
 neighbor 99.0.0.3 
 neighbor 99.0.0.4 


This post is licensed under CC BY 4.0 by the author.